Professional Email Degraded Accessibility

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Aug 13, 2026 - 10:00 BST

Investigating

We are currently investigating an issue affecting the ability to log in to webmail and email applications for the Professional Email service in North America region.
Posted Aug 13, 2026 - 09:49 BST
This incident affected: Email Services (Professional Email).