SSL Certificates Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Jan 19, 2026 - 15:22 GMT

Investigating

We are currently investigating an issue impacting issuance of new SSL certificates.
Posted Jan 19, 2026 - 13:58 GMT
This incident affected: Protect & Secure (SSL Certificates).