Hosting Dashboard Degraded
Incident Report for 123 Reg
Resolved
This issue has been resolved.
Posted Dec 20, 2024 - 21:05 GMT
Investigating
We are currently experiencing issues with the dashboard loading for cPanel & Plesk Hosting accounts in all regions.
Posted Dec 20, 2024 - 20:32 GMT
This incident affected: Shared Hosting (Web Hosting).