Professional Email Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Feb 26, 2026 - 01:01 GMT

Investigating

We are currently experiencing degraded email delivery to Microsoft accounts and are working to resolve this issue.
Posted Feb 25, 2026 - 10:43 GMT
This incident affected: Email Services (Professional Email).