Professional Email Degraded Accessibility

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Feb 26, 2026 - 15:29 GMT

Investigating

We are currently investigating an issue affecting the ability to log in to webmail and email applications for the Professional Email service in EU region.
Posted Feb 26, 2026 - 10:05 GMT
This incident affected: Email Services (Professional Email).