Renewals and Billing Page Degraded

Incident Report for 123 Reg

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 00:51 BST

Investigating

We are currently investigating an issue affecting customers' ability to manage the renewals and billing page within their accounts.
Posted Aug 05, 2026 - 21:10 BST
This incident affected: 123-reg.co.uk (123 Reg My Products Pages).