Microsoft Office 365 Email Degraded Accessibility
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Sep
01
,
2026
-
22:52
BST
Identified
We have identified the source of the issue and are currently applying a recovery fix across the system.
Posted
Sep
01
,
2026
-
07:12
BST
Investigating
We are currently investigating an issue affecting the ability to log in to Microsoft Office 365 webmail and email applications.
Posted
Aug
31
,
2026
-
17:57
BST
This incident affected: Email Services (Professional Email with Microsoft 365).
×
Subscribe to Incident
Subscribe to updates for
Microsoft Office 365 Email Degraded Accessibility
via . You'll receive .