Professional Email Degraded
Incident Report for 123 Reg
Resolved
This issue has been resolved.
Posted Dec 18, 2024 - 13:04 GMT
Investigating
We are currently investigating issues causing productivity.123-reg.co.uk services to be unavailable and latent.
Posted Dec 18, 2024 - 13:02 GMT
This incident affected: Email Services (Professional Email).