US Inbound Numbers All Down
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Apr
29
,
2025
-
22:50
BST
Investigating
We are investigating an issue that is causing all US inbound phone numbers to be down.
Posted
Apr
29
,
2025
-
22:45
BST
This incident affected: 123 Reg Support (Voice Support Services).
×
Subscribe to Incident
Subscribe to updates for
US Inbound Numbers All Down
via . You'll receive .