Managed Wordpress Services Degraded
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Apr
09
,
2025
-
07:04
BST
Investigating
We're currently investigating connectivity stability issues from european service providers to our Managed Wordpress environment
Posted
Apr
09
,
2025
-
00:18
BST
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).
×
Subscribe to Incident
Subscribe to updates for
Managed Wordpress Services Degraded
via . You'll receive .