Microsoft Office 365 Proofpoint Degraded Accessibi
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Jun
11
,
2025
-
21:49
BST
Investigating
We are currently investigating degraded services impacting the ability to access Proofpoint and delayed sending/receiving email
Posted
Jun
11
,
2025
-
19:40
BST
This incident affected: Email Services (Professional Email with Microsoft 365).
×
Subscribe to Incident
Subscribe to updates for
Microsoft Office 365 Proofpoint Degraded Accessibi
via . You'll receive .