Professional Email Degraded Accessibility
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Oct
13
,
2025
-
15:51
BST
Investigating
If you are experiencing an issue connecting to your email account, please ensure your password and server settings are correctly configured in your Email Client.
You can find step by step guidelines in the following articles:
https://www.123-reg.co.uk/support/email/purchasing-and-configuring-your-123-reg-mailbox/#ChangePassword
https://www.123-reg.co.uk/support/email/how-do-i-set-up-an-email-client-with-123-mail/
Posted
Oct
10
,
2025
-
12:34
BST
This incident affected: Email Services (Professional Email).
×
Subscribe to Incident
Subscribe to updates for
Professional Email Degraded Accessibility
via . You'll receive .