Online Store Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Mar 18, 2025 - 00:19 GMT

Investigating

We are currently investigating and issue impacting Online Store globally. Thank you for your patience.
Posted Mar 18, 2025 - 00:06 GMT
This incident affected: Websites and Stores (Online Store Builder).