Phone Support Degraded Services

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Mar 17, 2025 - 18:48 GMT

Monitoring

We are currently investigating an issue causing elevated call queues.
Posted Mar 17, 2025 - 17:11 GMT
This incident affected: 123 Reg Support (Voice Support Services).