Call Quality Degraded
Incident Report for
123 Reg
Resolved
This incident has been resolved.
Posted
Sep
10
,
2026
-
17:34
BST
Update
We are continuing to investigate this issue.
Posted
Sep
10
,
2026
-
17:03
BST
Investigating
We are aware of call quality issues impacting our support. Thank you for your patience.
Posted
Sep
10
,
2026
-
16:30
BST
This incident affected: 123 Reg Support (Voice Support Services).
×
Subscribe to Incident
Subscribe to updates for
Call Quality Degraded
via . You'll receive .