My Products Page Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Jul 23, 2025 - 11:18 BST

Investigating

We are currently investigating and issue preventing customers from managing the product pages within their account.
Posted Jul 23, 2025 - 08:14 BST
This incident affected: 123-reg.co.uk (123 Reg My Products Pages).