SSL Certificates Degraded
Incident Report for 123 Reg
Resolved
This issue has been resolved.
Posted Dec 18, 2024 - 07:03 GMT
Investigating
We are currently investigating an issue causing Secure Certificate creation to be delayed.
Posted Dec 18, 2024 - 06:17 GMT
This incident affected: Protect & Secure (SSL Certificates).