Ticket Support Services Degraded
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
Mar
15
,
2025
-
17:33
GMT
Investigating
We are currently investigating an issue impacting viewing and/or creating tickets for customer accounts.
Posted
Mar
15
,
2025
-
15:45
GMT
This incident affected: 123 Reg Support (Messaging Support Services).
×
Subscribe to Incident
Subscribe to updates for
Ticket Support Services Degraded
via . You'll receive .