Account Login Degraded

Incident Report for 123 Reg

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 23:59 BST

Investigating

We are currently investigating an issue with newly created accounts being unable to login. Teams are investigating and hope to have this resolved soon.
Posted Apr 10, 2025 - 18:34 BST
This incident affected: 123-reg.co.uk (123-reg.co.uk, 123 Reg Login Pages).