Sign in and Create Account Options Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Aug 21, 2026 - 22:08 BST

Identified

We are aware of issues preventing 123-reg.co.uk customers from signing in and/or creating accounts. We are working to resolve this. Thank you for your patience.
Posted Aug 21, 2026 - 21:55 BST
This incident affected: 123-reg.co.uk (123 Reg Login Pages).