Login Pages Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Jun 06, 2025 - 12:38 BST

Investigating

We are currently investigating an issue that is preventing clients from logging into their account.
Posted Jun 06, 2025 - 12:30 BST
This incident affected: 123-reg.co.uk (123 Reg Login Pages).