Order / Product Fulfillment Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Mar 30, 2025 - 18:25 BST

Investigating

We are currently investigating an issue causing issues with Orders for Ecommerce Wordpress. This may cause new orders to not appear correctly in your account while we work to address this.
Posted Mar 30, 2025 - 13:28 BST
This incident affected: 123-reg.co.uk (123 Reg Order & Product Fulfilment).