Website Builder Degraded Dashboard

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Apr 11, 2026 - 00:23 BST

Investigating

We are currently investigating an issue causing Website Builder publishing functionality to be unavailable and latent.
Posted Apr 10, 2026 - 23:46 BST
This incident affected: Websites and Stores (Website Builder).