Messaging Support Services Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Nov 13, 2025 - 15:04 GMT

Investigating

We are currently investigating an issue with our customer service chat. Please use our phone number to contact our customer support.
Posted Nov 13, 2025 - 10:14 GMT
This incident affected: 123 Reg Support (Messaging Support Services).