Managed WordPress Services Degraded
Incident Report for
123 Reg
Resolved
This issue has been resolved.
Posted
May
02
,
2025
-
20:01
BST
Investigating
We are currently investigating an issue with Managed WordPress sites being intermittently inaccessible.
Posted
May
02
,
2025
-
17:08
BST
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).
×
Subscribe to Incident
Subscribe to updates for
Managed WordPress Services Degraded
via . You'll receive .