Professional Email Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Aug 10, 2026 - 14:40 BST

Investigating

We are currently investigating an issue causing errors in the browser when trying to login into Webmail. If you see any errors in your favorite browser, please try using Microsoft Edge instead.
Posted Aug 10, 2026 - 10:50 BST
This incident affected: Email Services (Professional Email).