Messaging Support Services Degraded
Incident Report for 123 Reg
Resolved
This issue has been resolved.
Posted Feb 12, 2025 - 14:46 GMT
Investigating
We are currently investigating issues preventing access to customer service chat. Please use our phone number to reach our customer support.
Posted Feb 12, 2025 - 14:22 GMT
This incident affected: 123 Reg Support (Messaging Support Services).