Certificate Issuance Delayed

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Mar 27, 2025 - 17:04 GMT

Investigating

We are investigating an issue that is causing the issuance of certificates to be delayed for customers.
Posted Mar 27, 2025 - 16:57 GMT
This incident affected: Protect & Secure (SSL Certificates).