Microsoft 365 Web Suite Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Sep 08, 2026 - 18:56 BST

Investigating

We are currently aware of customers being unable to access the Microsoft 365 Web Suite. We are working with teams to resolve the issue.
Posted Sep 08, 2026 - 16:59 BST
This incident affected: Email Services (Professional Email with Microsoft 365).