VPS Provisioning Delay
Incident Report for 123 Reg
Resolved
This issue has been resolved.
Posted Dec 28, 2024 - 08:36 GMT
Investigating
We are currently investigating an issue with VPS provisioning in all regions.
Posted Dec 28, 2024 - 01:24 GMT
This incident affected: Advanced Hosting (Virtual Private Server (VPS)).