Microsoft Office 365 Email Degraded Accessibility

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Jan 23, 2026 - 06:37 GMT

Investigating

We are aware of connectivity issues with Microsoft 365 services impacting customers' ability to access and use Office 365 services. We are investigating the issue with Microsoft to return service to normal as soon as possible.
Posted Jan 22, 2026 - 20:07 GMT
This incident affected: Email Services (Professional Email with Microsoft 365).