DNSSEC Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Sep 27, 2025 - 17:49 BST

Investigating

We are currently investigating an issue impacting DNSSEC in all regions.
Posted Sep 27, 2025 - 17:44 BST
This incident affected: Domain Services (DNS).