Domain Registration Degraded

Incident Report for 123 Reg

Resolved

This issue has been resolved.
Posted Apr 20, 2026 - 15:01 BST

Investigating

We are currently investigating an issue affecting new registrations and renewals.
Posted Apr 20, 2026 - 13:16 BST
This incident affected: Domain Services (Domain Registration).